PSA Reporting Data Sync Issue

Incident Report for ISOutsource Internal IT

Resolved

This incident has been resolved.
Posted Oct 27, 2025 - 09:57 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 27, 2025 - 09:41 PDT

Identified

We’re aware of an issue preventing PSA data from updating in internal reports and are actively working to resolve it.
Posted Oct 27, 2025 - 08:54 PDT
This incident affected: Corporate Services (Reporting Services).