Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 02, 2025 - 15:30 PDT
Scheduled
We are performing an urgent maintenance window for ScreenConnect today at 3:30 PM. The planned duration is 2 hours, though we are aiming to complete it much sooner. This action is required due to a mandate from ConnectWise that forces an update within a very short timeframe.
Posted Jul 02, 2025 - 11:33 PDT
This scheduled maintenance affected: Corporate Services (ScreenConnect).