Regional Power Outage
Incident Report for ISOutsource Internal IT
Update
We continue to monitor the situation and are standing by for power to be restored to the region to bring the remaining services back online.
Posted Nov 20, 2024 - 16:25 PST
Identified
Regional power outages from the November 19th storm have a few of our systems and locations offline at this time.
Posted Nov 20, 2024 - 06:30 PST
This incident affects: Office Networks (HQ Office Network) and Corporate Services (File Server(s), Certificate Services, Direct Access, Print Management Services, Accounting Applications, Terminal Services, Reporting Services).